Skip to content

OpenLogReplicator process 100% CPU on shutdown #328

Description

@Naros

When starting OpenLogReplicator and if a missing grant is found, OLR logs show:

olr     | 2026-07-27 06:22:58 INFO  00000 client requested to start from scn: 2379989
olr     | 2026-07-27 06:22:58 INFO  00000 connecting to the database instance of ORCLCDB to //oracle:1521/ORCLCDB
olr     | 2026-07-27 06:22:59 INFO  00000 version: Oracle Database 19c Enterprise Edition Release 19.0.0.0.0 - Production, context: ORCLCDB, resetlogs: 0, activation: 0, con_id: 1, con_name: CDB$ROOT
olr     | 2026-07-27 06:22:59 HINT  run: ALTER SESSION SET CONTAINER = CDB$ROOT;
olr     | 2026-07-27 06:22:59 HINT  run: GRANT SELECT, FLASHBACK ON SYS.COL$ TO c##dbzuser;
olr     | 2026-07-27 06:22:59 ERROR 10034 grants missing for table SYS.COL$
olr     | 2026-07-27 06:22:59 INFO  00000 Replicator for: ORCLCDB is shutting down
olr     | 2026-07-27 06:22:59 INFO  00000 Memory HWM: 32MB, builder HWM: 1MB, misc HWM: 0MB, parser HWM: 0MB, disk read buffer HWM: 0MB, transaction HWM: 0MB, swapped: 0MB, disk write buffer HWM: 0MB

At this point, the OpenLogReplicator process enters a high CPU churn and is only mitigated by killing the process/container.

Ideally, if a GRANT is missing

  • OpenLogReplicator reports the error, disconnects the client, and waits for a new connection
  • Does not enter a high CPU churn

This allows the user to make adjustments and reconnect the network client with ease.

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions