Skip to content
This repository was archived by the owner on Sep 26, 2023. It is now read-only.
This repository was archived by the owner on Sep 26, 2023. It is now read-only.

openshift-multus: admission webhook "check-ignore-label.gatekeeper.sh" denied #238

Description

@laurobmb

Hey,
after installing gatekeeper operator on openshift cluster it gives an error in operator do network

oc describe co network
Message: Error while updating operator configuration: could not apply (/v1, Kind=Namespace) /openshift-multus: could not update object (/v1, Kind=Namespace) /openshift-multus: admission webhook "check-ignore-label.gatekeeper.sh" denied the request: Only exempt namespace can have the admission.gatekeeper.sh/ignore label

I noticed that the ValidatingWebhookConfiguration/gatekeeper-validating-webhook-configuration feature doesn't have matchExpressions to ignore the label, is that right? because I solved the problem by applying a change to the resource putting the
"matchExpressions": [
{
"key": "admission.gatekeeper.sh/ignore",
"operator": "DoesNotExist"
in the resource

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions